NYC - Urgent Datacenter Maintenance

Incident Report for AlphaVPS Status

Resolved

The incident is fully resolved.
Posted May 31, 2025 - 15:59 EEST

Identified

We've been informed of an urgent DataCenter maintenance in our NYC facility, affecting some of our services there. ETA of service restoration is 1-2 hours.
Posted May 31, 2025 - 06:59 EEST
This incident affected: New York, United States (Network Infrastructure in New York).