Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 21, 2026 - 17:00 EEST
Scheduled
We are scheduling emergency network maintenance in our Los Angeles location today, August 21, 2026.
Our datacenter team will be replacing a network switch serving our rack. The maintenance window is scheduled between 7:00 AM and 12:00 PM PDT, with an expected service interruption of approximately 30 to 60 minutes during the replacement.
An email notification regarding this maintenance was sent to affected customers earlier today.
We will post further updates here as the maintenance progresses and confirm once connectivity has been fully restored.
Posted Aug 21, 2026 - 14:12 EEST
This scheduled maintenance affected: Los Angeles, United States (Network Infrastructure in Los Angeles).